FN Herstal Firearms banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Took one of my ps90's out for a second time. And some of the rounds did not fire. This happened four times.

I was useing 195 from four diffrent box's. Wepon was cleaned and in good order. Back of primer did not have a strike on the four rounds. They did fire a second time though.

They were the fifth thirtyis round and tenth and last was a twenty round in mag. I used three diffrent mags. All mags new too.

Just wanted to know if this has happned to any one eles? Or if a bad batch of ammo is out. But all rounds did fire the second time I loaded them.
 

·
Registered
Joined
·
15,557 Posts
I've never had this happen before. I'd see if it happened again. If it continues, U will probably have to send it into the manufacturer, unfortunately.

Of course - someone else here might have a brilliant idea I haven't thought of :p
 

·
Registered
Joined
·
569 Posts
With no primer strike visible it sounds like the firing pin isn't moving freely in its channel. Since FN packs the PS90 w/a special "storage lubricant" that must be removed & replaced w/std lubricant I suggest you try cleaning the breech block again w/special attention paid to the firing pin and its opening to ensure all the original storage lubricant is removed and nothing is binding on the firing pin. If you continue to experience the same problem then I'm w/Shipwreck, it's time to contact FN.
Tomac
 

·
Registered
Joined
·
36 Posts
I agree with Tomac. My PS90 was quite "gunky" inside when I got it and it took a more through cleaning than most new guns I've purchased in the last few years.

Easy place to start at least.
 
1 - 6 of 6 Posts
Top