FN Herstal Firearms banner
1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I recently purchased my FNP9-M SAO and though I've only shot 100 rounds thus far, I have had a consistant problem: the slide doesn't seem to be working all the way back. Also, when I tore the gun down, there was a very gold line from where the bottom of the slide had rubbed against the "on deck" round in the mag.

On the first magazine, I never had a clean reload, problems consisted of:
~ The expended brass getting caught on it's way out of the chamber
~ The slide not catching on the rear of the next bullet, but rather just before the rear causing the next bullet to exit the magazine strangly and not enter the chamber
~ The slide not locking back on the last shot of a magazine

I know it's only 100 rounds and the gun won't hit it's full stride for another few hundred rounds, but I had the problems listed above throughout the 100 rounds. I would say only about 1 rounds fed correctly after a shot, but the slide never locked back on the last one.

I've heard of a possible cause being my shooting stature, that I'm absorbing some recoil with my shoulder. This is a possibility because I've been shooting with my weak hand (recent surgery on the other elbow), but I have shot a friend's new M9 in this manner w/o a problem.

Currently the firearm is sitting with the slide locked open in case the spring is just a little tight, hopefully it will loosen-up, but it seems like that won't fully solve all my problems.

Thanks for the help.
 

·
Registered
Joined
·
15,562 Posts
Polymer guns are a bit more prone to limpwristing than metal guns.

Leave the slide locked back like that for a while, and also try to have your friend shoot the gun - to see if it is the way you are shooting because of your injury.

If still not working - call bob:

Bob Ailes
Customer Support Manager
PO Box 697
McLean, VA 22101
T: 703-288-1292 ext-122
F: 703-288-1730
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
After rereading your thread, Shipwreck. I assume I'm having the same problem, but did you encounter any issues with the slide not grabbing bullets from behind, but rather in the middle to rear-third of the cartridge? I don't know if this is a result of the same issue and my only thought would be something with the magazine, but this happened on each of the three mags.

Also, my friend did shoot it and it functioned flawlessly, but only for a third of a mag. I'll have t have him shoot some more for a difinitive answer.
 

·
Registered
Joined
·
15,562 Posts
My gun worked 100% - I just had some initial issues with the empty mag not locking the slide back - and ejected cases hitting me in the face. After 150 rounds - the slide lockback went away... And, now I get some cases raining on me every once in a while - but they go higher now...

I never had the issues you describe. I'd call Bob.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
Actually it was just Remington 115g FMJ which I would assume many of you have used in your FNP9's. I'll get a chance to shoot it a bit more this weekend, then we'll see what happens. I just bought 500 rounds so we'll see what I can do. I've taken some advise and left it with the slide locked back and I rack the slide a couple hundred times a night, just to get a little wear on it.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Good news, I just got back from the range and the gun fired 200 rounds flawlessly! No more problem with the slide not working all the way back, but there is still a bit of wear on the bottom of the slide from the next cartridge in the magazine, but I figure if I keep it lubed enough, it's not a problem.

Thanks for the help!
 

·
Banned
Joined
·
4,097 Posts
Glad to hear the issue is resolved. Enjoy your FN!! :? :grin:
 
1 - 10 of 10 Posts
Top