FN Herstal Firearms banner

1 - 14 of 14 Posts

·
Registered
Joined
·
857 Posts
Discussion Starter #1
Ok - I got mine installed per the pictures on this sight and the directions.
I got both light collectors covered.
Unit works fine indoors but as soon as i point it towards a window - I got nothing, can't see the sight at all.
I tried changing the battery and still nothing.

Any idea what i did wrong? I'f it donesn't work in daylight it's useless to me since that's where i do all my shooting.
 

·
Vendor
Joined
·
5,651 Posts
Check to see that both LEDs are lit when you are on setting #11. We did have a problem on some where only one LED would light up when set on #s 10 and 11. We thought we fixed that problem.
You should be able to see the T bar when looking out windows. It is only faint when looking at a sun lit bright background. Sorry, best I could do.
If there is a problem with the LEDs Let me know so I can send you a new one.
If you decide this unit is not good enough for your use then let me know and you can send it back and I will give you a full refund.

Thanks
 

·
Registered
Joined
·
857 Posts
Discussion Starter #3
Both led's are lit.

I fooled with it a little and got it to light up the sight better as to where it is day light visible.

They only way i could get it to work was insert the front end first and angle it down, but that left the rear end sticking up with the wire in the way of your view. When i put it in the corrrect way with the back flush, it doesn't light up the sight enough for even a brightly lit room.
 

·
Vendor
Joined
·
5,651 Posts
hmmm ... are the LEDs on the longer shallower angled side or the on the shorter steeper angled side? They should be on the longer shallower angled side. If not, the LED housing was made wrong. It has happened befor so let me know.
 

·
Registered
Joined
·
857 Posts
Discussion Starter #5
They are in the correct spot -
but if i seat it in so it's flush it doesn't work right
when i angle it so the front is lower and the back is higher it works fine, i'll see if i can post some pictures soon.
 

·
Vendor
Joined
·
5,651 Posts
Oh Good OK Thanks, I'm just wonder if your LEDs were positioned a little too high. They have to be just right to get a good sight picture. I'll let Brian know and I'll send you another one out of the next batch and you can send me back that one so I can test it. I'll send you a couple extra batteries for your trouble.

Chris
 

·
Registered
Joined
·
857 Posts
Discussion Starter #7
Here's the pictures.

- first one is of the rem so you can see where the leds are




This picture shows the rem installed correctly where it is not lighting up the recticle properly.




This shows the rem with the front angled down - in this position it works well but the back is up too high

 

·
Vendor
Joined
·
5,651 Posts
Everything looks right. hmmm.... I'll send you a replacement when I get some more in. It will be about 3 to 4 weeks. :?

The Ring Sights front light collector (dohnut) should be the main sight used in day light. The REM 2 is the back-up to be used when the "dohnut" is too dim to see.
 

·
Registered
Joined
·
857 Posts
Discussion Starter #9
I could try and sand it down some so it fits better
As long as i get your permission so if i F it up, i'm not stuck with it.
 

·
Registered
Joined
·
857 Posts
Discussion Starter #12
Ok - I got out my grinder and grounded down the bottom and back

It seem to fit perfectly and actually stays in place with out the tape, before it was popping up even with the tape.

It seem to be lighting up the reticle properly now, but i still have to test it in day light then I'll let you know.
 

·
Vendor
Joined
·
5,651 Posts
As per our PM's... I'm glad you got yours to work properly. :?
Let me know if you have any other issues.

I'll start sending the REM 2s out with a thicker double sided tape. That will allow a better adhesion.
 
1 - 14 of 14 Posts
Top