FN Herstal Firearms banner
1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I took my FNS 9 out to shoot yesterday and after cleaning I inserted the magazine into the gun and racked the slide to load a round into the chamber. I noticed the chamber indicator is not showing the typical red dot. I tried it a couple of times with the same result. The gun shot fine yesterday.

What could be the cause and what can I do to repair?

thanks
 

·
Registered
Joined
·
21,553 Posts
Don't worry about it, there's nothing wrong with it, they typically don't stick out much and a lot of time the red dot falls off or gets dirty anyway. It's an afterthought to satisfy the lawyers and whichever states require a LCI.
 

·
Registered
Joined
·
65 Posts
I don't really go by the visual red indicator, I prefer running my support thumb over the LCI to feel whether it's flush (empty chamber) or elevated (loaded chamber). This method works with or without light.

Does yours still work this way?
 

·
Registered
Joined
·
128 Posts
We have a loaded chamber indicator?! Just kidding, the red is sooooo dark and doesn't even stick out that far, I don't even use it. Plus my whole slide it TiN coated and it washes the color out more. I always just check clear before I leave home and re chamber on before it goes in my holster.
 

·
Registered
Joined
·
38 Posts
I apparently do not have such an indicator. I think I see where it would be. But, nothing changes between cartridge chambered or not.

Is it possible that they are only on the models that have a safety?

Doc
 

·
Registered
Joined
·
21,553 Posts
I apparently do not have such an indicator. I think I see where it would be. But, nothing changes between cartridge chambered or not.

Is it possible that they are only on the models that have a safety?

Doc
It's the extractor. So you have it, unless you don't have an extractor...

It may only move a millimeter or so, but it does move. With your fingernail, pull out on the extractor claw and you should see a little indented area that may or may not have red paint in it.
 

·
Registered
Joined
·
38 Posts
It's the extractor. So you have it, unless you don't have an extractor...

It may only move a millimeter or so, but it does move. With your fingernail, pull out on the extractor claw and you should see a little indented area that may or may not have red paint in it.
Yeah, I am looking in the right place then.

Girlfriend and I sat here and I chambered and cleared a full mag and neither of us can see even a milimeter of difference. and nothing red.

Oh well, I am not bothered. I never would have trusted it anyways.

My dad's very first most important rule was " A gun is ALWAYS loaded until YOU clear it yourself "

Doc
 

·
Registered
Joined
·
65 Posts
Yeah, I am looking in the right place then.

Girlfriend and I sat here and I chambered and cleared a full mag and neither of us can see even a milimeter of difference. and nothing red.

Oh well, I am not bothered. I never would have trusted it anyways.

My dad's very first most important rule was " A gun is ALWAYS loaded until YOU clear it yourself "

Doc

So when you run your thumb over the LCI, it's flush to the slide regardless of whether the chamber is loaded or not?
 

·
Registered
Joined
·
65 Posts
Nope, nothing is flush or elevated.

Doc

??? The LCI has to either be flush or elevated compared to the slide, one or the other.

If you run your thumb over the LCI (do this in the dark or keep your eyes closed) and it does NOT protrude from the slide, then it's flush which means the chamber is empty. Do the same thing with a loaded chamber and the LCI should protrude from the slide like a bump.
 

·
Registered
Joined
·
65 Posts
HAH!

There it is. Need a micrometer to measure it. But, I just and I mean just feel it in the fingerprint of my finger.

Good thing I won't ever rely on it, I guess.

Doc
You may want to consider having FNH or an trained FNH gunsmith look at the LCI if nothing else than to ensure the extractor functionality of it is working properly. It's very odd that it protrudes only just barely when loaded.
 
1 - 13 of 13 Posts
Top