FN Herstal Firearms banner

1 - 6 of 6 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1 (Edited)
Sorry guys I know your tired of seeing all my silly threads.

Yesterday I went to the range and I got a click and no bang. Pulled bolt back and I noticed a round was almost chambered but did not fully seat. I thought oh boy its going to be a short range day because I didnt bring my tools with me. Too my surprise the round slipped out when I brought it vertical and I though hmm. I inspected the round and everything looked ok .... so I put it in and shot it fine. Didnt think TOO much into it, I was shooting American Eagle and I know their reputation is not so good.

So I go back today and it happened again, this time I was shooting the SS197. Now I am a bit more worried. I *think* it was the same magazine and even maybe around the same stack count but Im not 100% sure. I definitely marked it this time. The magazine itself doesnt seem to have any issues, the guide slides in and out no problem and I already have the man kave delrin rollers.

After the malfunction I did end up shooting 100 more rounds without the issue, this time using my other magazines.

I tried to replicate the malfunction by having my snap caps positioned in a weird way to make it slip but I cant seem to do it. The only way I can replicate the malfunction is if I slowly ride the bolt home.

I have attached a picture of what the malfunction looks like below.



https://i.imgur.com/Z93eovW.jpg


20200607_171557.jpg
 

·
Registered
Joined
·
3,533 Posts
I would make sure there's some tension and the extractor can move, and them make sure it didn't have some freak occurrence and chip off?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
I would make sure there's some tension and the extractor can move, and them make sure it didn't have some freak occurrence and chip off?
Thank you for answering me, I really enjoy your YT videos btw.

The extractor does not seem stuck.
 

·
Vendor
Joined
·
3,282 Posts
I believe there was some bad voodoo in several threads over the years with " riding the ch back". OR at least to my best memory! I have read some really strange experiences over the years. Don't read too much into the problem. Many times if members would stick with the better ammo 50% of the strange issues would not happen.
So in short (besides checking for some type of damage)... if you (A) don't ride the charging handle home and...(B) use SS195,SS197 or SS198 ammo it may not happen again.

Just an observation.
 

·
Registered
Joined
·
1,394 Posts
I had the same malfunction last time i shot my PS90. Only in my case I found the separated necks of some apparently bad reloads still in the chamber.
Had the same experience once myself. A full scrubbing of the chamber later (after removing the piece of case neck) and I've never had the problem happen again.
 
1 - 6 of 6 Posts
Top